Extended Time to Send Campaigns
Incident Report for TextUs Next
Resolved
This incident has been resolved, all pending campaigns have been processed and campaign send times have returned to normal.
Posted Jul 13, 2021 - 11:54 MDT
Monitoring
We are aware of reports of extended waiting times when sending campaigns. We have identified the cause of delay and are currently working quickly through the backlog to process waiting campaigns.
Posted Jul 13, 2021 - 11:02 MDT
This incident affected: TextUs Next Web App.