Help Center and Support Portal Outage
Incident Report for TextUs Next
Resolved
This incident has been resolved.
Posted May 12, 2021 - 06:58 MDT
Investigating
At this time both the Help Center for TextUs and the ticketing platform are currently unavailable. We are working to restore full functionality. If you have a pressing issue and need immediate assistance please reach out to your account manager. In the meantime, please send any other requests to support@textus.com and we will answer them in the order they are received.

TextUs services and applications are still fully operational at this time!
Posted May 11, 2021 - 15:31 MDT