The scheduled maintenance has been completed successfully. All systems and services are operating normally.
We will continue to monitor system performance closely to ensure ongoing stability. Thank you for your patience and understanding during this maintenance period.
Posted Oct 09, 2025 - 22:33 MDT
Verifying
The scheduled maintenance has been completed successfully. Our team is now performing post-maintenance verification to ensure all systems are fully operational and performing as expected.
The application remains fully available during this verification process. Users may continue to log in, send messages, and access all features as usual.
We will post a final confirmation once verification is complete and the maintenance window is officially closed.
Posted Oct 09, 2025 - 22:07 MDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 20:00 MDT
Scheduled
TextUs will be undergoing scheduled maintenance on Thursday, October 9, 2025, starting at 8:00 PM MT. The maintenance window is expected to last up to 2 hours. During this time, the TextUs application will be temporarily unavailable. However, any scheduled, inbound, or outbound messages will continue to be delivered without interruption.
If you have any questions, the TextUs Support team is here to help.
Posted Sep 25, 2025 - 07:28 MDT
This scheduled maintenance affected: TextUs Application, TextUs Chrome Extension, and TextUs Mobile App.