Delay in ending Scheduled Campaigns
Incident Report for TextUs
Resolved
This incident has been resolved.
Posted Dec 02, 2021 - 11:28 MST
Monitoring
We are currently monitoring reports that there is a delay in sending scheduled campaigns.

We will post another update as soon we we know more.
Posted Dec 02, 2021 - 10:49 MST
This incident affected: TextUs Application.