Support Platform Provider Experiencing Issues
Incident Report for TextUs Next
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 15:02 MDT
Monitoring
Some users may experience intermittent errors when contacting support. Our support platform provider is seeing elevated error rates.
Posted Jun 09, 2021 - 11:44 MDT
This incident affected: Supporting Applications (Customer Support Platform).