10DLC Campaign and Brand Registration Delays
Incident Report for TextUs
Resolved
This incident has been resolved.
Posted Feb 28, 2022 - 14:59 MST
Identified
Our 10DLC provider is actively investigating an issue that is impacting brand and campaign registrations. Not all accounts will be affected. We will continue to post updates here as they become available.
Posted Feb 28, 2022 - 11:28 MST