Some Verizon multi-segment SMS messages delivering out of order
Incident Report for TextUs Next
Resolved
Multi-Segment SMS messages are no longer being delivered out of order or split. This incident has been marked as resolved by our upstream provider.

If any new issues arise following this update please reach out to support.
Posted Jul 16, 2021 - 12:49 MDT
Investigating
SMS provider teams are currently investigating an incident impacting SMS messages to Verizon.

Specifically, Multi-Segment SMS messages may deliver out of order or split.

All teams are actively engaged. We will update as we know more.
Posted Jul 16, 2021 - 11:52 MDT
This incident affected: SMS Providers (Secondary Provider SMS/MMS).